Jump to content
Arkivverket
Sign in to follow this  
Guest Leif Biberg Kristensen

[#73407] Feil i lenke NTS 6 (1703-1709)

Recommended Posts

Guest Leif Biberg Kristensen

Da har jeg funnet min første feil i dette ellers utmerkede systemet: Ved oppslag på Nedre Telemark Sorenskriveri (Lenke Telemark sorenskriveri&protokoll=&periode=&navn=) peker lenka til protokoll nr. 6 (1703-1709) til siste side i protokollen, som er en filmingsplakat med påskriften «The End». Ved manuelt å skrive inn et 1-tall i sidefeltet kommer man imidlertid raskt til begynnelsen av boka. Dette retter dere sikkert raskt og effektivt :)mvh Leif

Share this post


Link to post
Share on other sites
Guest Leif Biberg Kristensen

Så bør dere kanskje sørge for at lenker fra denne tjenesten lar seg klippe og lime inn her på forumet ...

Share this post


Link to post
Share on other sites
Guest Kristian Hunskaar

Som jeg antok da jeg så innlegget ditt i går kveld, er det en indekseringsfeil her. Samtlige bilder, med unntak av det aller siste, er indeksert som registersider. Det siste bildet er det første og eneste som er indeksert som skifteprotokollside, og dermed er det dette bildet som lenka går til.Jeg satser på å rette dette i løpet av uka, slik at rettelsene kommer med i førstkommende oppdatering mot web (natt til lørdag).Lenkeproblemet skyldes at programmet WebDebatt, som styrer debattene i foraene, ikke forstår at en URL kan inneholde mellomrom.---.arkivverket.no/URN:sk_read/search?forvaltning=&fylke=08&embete=Nedre Telemark sorenskriveri&protokoll=&periode=&navn=Når et søkekriterium, her 'Nedre Telemark sorenskriveri', inneholder mellomrom, skjer dette. Og slik feil får jeg når jeg tester samme lenke i et annet forum jeg er mye innom, også, så det er ikke unikt for programmet WebDebatt.

Share this post


Link to post
Share on other sites
Guest Leif Biberg Kristensen

Takk for svar. Mellomrom i url'er er noe herk. Det er helt trivielt programmeringsmessig å bytte dem ut med understreker (_) uten å gjøre url'en mindre lesbar, - bare som et forslag. Da ville lenka mi bli Lenke -som bør fungere helt greit.

Share this post


Link to post
Share on other sites
Guest Kristian Hunskaar

Da fant jeg en snarvei så jeg slapp å indeksere hele protokollen på nytt. Vi ser på lørdag om det fungerer, og hvis ikke, biter jeg i det sure eplet og tar alt forfra.Joda, det er sikkert triviell programmering. Men nå skal Digitalarkivet nyskrives (arbeidet med kravspesifikasjon har startet), og da forsvinner uansett programmet WebDebatt.

Share this post


Link to post
Share on other sites
Guest Leif Biberg Kristensen

Det er jo ikke WebDebatt som er problemet her, men mellomrom i lenker, som ikke bør forekomme uansett.

Share this post


Link to post
Share on other sites
Guest Kristian Hunskaar

Test: Lenke Telemark sorenskriveri&protokoll=&periode=&navn=

Share this post


Link to post
Share on other sites
Guest Kristian Hunskaar

OK, skjønner hvor du vil! Jeg har testet litt til, og etter min forståelse er det (i utgangspunktet) ikke programmet for skanna kirkebøker som er problemet.Når du velger fylke = telemark og embete = Nedre Telemark sorenskriveri og klikker utfør, blir URLen---.arkivverket.no/URN:sk_read/search?forvaltning=&fylke=08&embete=Nedre[pluss]Telemark[pluss]sorenskriveri&protokoll=&periode=&navn=Programmet for skanna kirkebøker fyller inn pluss-tegn i de åpne mellomrommene, her markert med [pluss] fordi WebDebatt tydeligvis fjerner pluss-tegn og erstatter dem med mellomrom (ditto har jeg opplevd for tegnene 'større enn' og 'mindre enn'). Dette skjer ikke i et annet debattforum jeg nettopp testet.Men jeg antar at vi kan komme rundt dette ved å bruke understrek i stedet for pluss.

Share this post


Link to post
Share on other sites
Guest Leif Biberg Kristensen

Det er vanlig at en søkestreng transponert til en GET-variabel erstatter mellomrom med plusstegn, ja.Det forundrer meg at dette søkeresultatet skal avhenge av et fritekstsøk i databasen. Mener du virkelig at det ikke er laget noen tabell over jurisdiksjoner, som dette søket skal slå opp i? Det tyder etter min mening på dårlig normalisering.

Share this post


Link to post
Share on other sites
Guest Anette Skogseth Clausen

Vi beklager at vi har et noe overivrig korrektursystem i debattforumet. Vi har opplevd at tråder blir uleselige pga gal bruk av hakeparenteser og andre tegn som også kan forekomme i html-kode, så det har gjort at systemet fjerner 'farlige' tegn med en gang.For å være sikret at en får gjengitt url-en korrekt, kan en bruke en url-forkorter, f.eks. http://www.tiny.cc/

Share this post


Link to post
Share on other sites
Guest Leif Biberg Kristensen

Jeg synes man bør være forsiktig med å anbefale url-forkortning. Slike kryptiske lenker sier jo absolutt ingen ting om hvor man havner, og jeg klikker av prinsipp ikke på dem selv om jeg sitter med en Linux-PC og dermed er atskillig bedre sikret mot vandalisme, trojanere, XSS og gud vet hva enn alle de som sitter med Internet Explorer på en Windows-PC.For det første bør dere sørge for at deres egne systemer lager «spiselige» lenker, og for det andre burde ikke Debattforum-softwaren være fullt så paranoid.

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.