Jump to content
Arkivverket
Anne-Lise Hansen

Permanent sidelenke virker ikke

Recommended Posts

Anne-Lise Hansen

Om en kopierer de to øverste linjene i Bildeinformasjonen, (eller alle tre), så er ikke sidelenken noen lenke når det blir lagt inn i et innlegg. Se melding om dette gitt i denne tråden og svaret som er gitt der: http://forum.arkivve.../#entry1521243.

 

Jeg er klar over at en får lagt inn lenke om en bare kopierer sidelenken og ikke det rundt, men det er uheldig om det fortsetter å være sånn, for da kommer folk til å droppe å ta med kildeinformasjonen. Etter min mening er informasjonen om hvilken kilde ting er hentet fra viktigst, for lenker kan råtne, men da vet en i det minste hvor det er funnet.

Share this post


Link to post
Share on other sites
Anette S. Clausen

Det ser ut til å være nettleseravhengig. Jeg opplever ikke feilen når jeg bruker Chrome, men får den når jeg bruker Firefox.

Share this post


Link to post
Share on other sites
Anne-Lise Hansen

Feilen oppstår altså ved bruk av Internet Explorer eller Firefox (se Testforumet: http://forum.arkivve...r/#entry1521298)

 

Siden denne feilen har oppstått nylig, må det være grunn til å spørre om det er endringer i Forumprogrammet IP-Board som forårsaker denne feilen? Jeg har ikke noen tro på at det er Firefox eller IE fra brukernes side som legger til  -koden foran sidelenke-URL'en i Kildeinformasjonsfeltet.

 

Hvorfor kommer denne koden?

 

Vil det bli gjort endringer fra Digitalarkivets side for å rette på dette?

 

Personlig kommer jeg ikke til å bytte nettleser denne gangen.

.

Edited by Anne-Lise Hansen

Share this post


Link to post
Share on other sites
Anne-Lise Hansen

Javel, så virker IE.

 

Jeg ønsker likevel å få svar på spørsmålene jeg stilte.

Share this post


Link to post
Share on other sites
Anne-Lise Hansen

Nå begynner jeg å bli alvorlig bekymret for at det ikke bare er blitt trøblete å legge inn lenker, for nå har jeg funnet at

lenker som tidligere har fungert er blitt ødelagt senere.

 

Jeg har nå sittet og reparert lenker jeg tidligere har lagt inn i flere tråder og da jeg kom til denne tråden: http://forum.arkivve...20#entry1503707 forsto jeg at lenkene i tillegg er blitt ødelagt i ettertid. Som belegg for dette er innlegg #95 og #96: http://forum.arkivve...80#entry1505522 hvor nettopp det å lage permanente lenker var tatt opp som tema inne i tråden. Jeg vet at trådstarter la inn fungerende lenker i dette innlegget og nå er ikke sidelenken det lenger.

 

Det er også påfallende at så mange lenker ikke fungerer i innleggene til flere av deltakerne i tråden.

Slik var det ikke da samtalen pågikk! Da virket de fleste av lenkene.

 

Jeg har altså kommet tilbake til april og setter disse forandringene i forbindelse med oppdateringen av forumet.

 

EDIT: Lenkeråten har bredt seg til innlegg fra forumet ble åpnet: http://forum.arkivve...-kyst/#entry677

Edited by Anne-Lise Hansen

Share this post


Link to post
Share on other sites
Anne-Lise Hansen

Jeg har ikke noen tro på at det er Firefox (..) fra brukernes side som legger til  -koden foran sidelenke-URL'en i Kildeinformasjonsfeltet.

 

Hvorfor kommer denne koden?

.

.

 

I Kildeinformasjonsfeltet er URL'ene til Sidelenke og Bildelenke justert slik at http etter Sidelenke kommer rett ovenfor http etter Bildelenke,

(sikkert fordi det lay-outmessig ser penest ut):

 

Permanent sidelenke: http:................................

Permanent bildelenke: http:................................

 

For å få det til å ligge slik, er det satt inn to harde mellomrom etter Sidelenke ( ) og ett hardt mellomrom etter Bildelenke.

 

Om en fjerner det ene av de to harde mellomrommene foran http, når en skal legge inn lenke, fungerer URL'en som en lenke,

(se innlegg i Testforum: http://forum.arkivve...r/#entry1521311)

 

 

Spørsmålet er derfor om Digitalarkivet kan fjerne det ene av de to harde mellomrommene (etter Sidelenke) i kirkeboksidenes kildeinformasjonsfelt,

slik at også Firefox-brukere (om dette er årsaken), kan lage fungerende sidelenker.

Share this post


Link to post
Share on other sites
Leif Biberg Kristensen

Test: Samme lenke som Frank la inn over her. Firefox 10.0.5 på Linux. Rå klipp og lim.

 

Kildeinformasjon: Nordland fylke, Gildeskål, Ministerialbok nr. 805A09 (1909-1926), Fødte og døpte 1916, side 41.

Permanent sidelenke: http://www.arkivverket.no/URN:kb_read?idx_kildeid=2833&idx_id=2833&uid=ny&idx_side=-47

Permanent bildelenke: http://www.arkivverk...50329020514.jpg

 

Redigert. Nå forsøker jeg å gjøre som Anne-lise foreslår og fjerner mellomrommene mellom : og http i sidelenka, og deretter legger inn ett vanlig mellomrom:

 

Kildeinformasjon: Nordland fylke, Gildeskål, Ministerialbok nr. 805A09 (1909-1926), Fødte og døpte 1916, side 41.

Permanent sidelenke: http://www.arkivverk...ny&idx_side=-47

Permanent bildelenke: http://www.arkivverk...50329020514.jpg

 

Bingo.

 

Vil dere være snille og få rettet opp i dette? Som gammel websnekker ser jeg ingen grunn til å prioritere estetikk på bekostning av funksjonalitet. Skal dere absolutt laine opp teksten så bruk heller en tabell eller div'er, da. Å putte inn nbsp-er for å justere tekst er amatørmessig.

Share this post


Link to post
Share on other sites
Anne-Lise Hansen

Nå er http etter Sidelenke flyttet tilbake igjen (til rett over http etter Bildelenke) og det legges på ny ut sidelenker som ikke virker.

Det at dere flyttet sidelenke-url'en én posisjon til venstre, løste problemet for Firefox-brukerne, http://forum.arkivverket.no/topic/182145-lenker-fra-kirkeboeker-sidelenk-ikke-klikkbar-program-feil/#entry1548144

men nå er det altså like galt igjen.

 

Jeg som hadde byttet til Opera, gikk tilbake til Firefox igjen, siden det var ordnet, men nå nå jeg altså bytte igjen?

 

Kan dere gjøre om på det?

Share this post


Link to post
Share on other sites
Bent Vangli

Hei. Jeg skal fikse dette. Skyldes nok at jeg jobber med å komme rundt problemene med at buffere går full og har nok kommet i skade for å legge inn den der koden fra kodebasen min. Mvh Bent

Share this post


Link to post
Share on other sites
Bent Vangli

Er det bedre nå. Har tatt bort den koden som feilaktig kom med. Beklager. Mvh Bent

Share this post


Link to post
Share on other sites
Anne-Lise Hansen

Jeg mener ikke å mase, (og det haster forsåvidt ikke heller), for du har nok sett at innstillingene i Kildeinformasjonsfeltet er tilbake til slik de var, da dette skapte problemer for Firefox-brukerne. (Jeg vet at dette er et fillespørsmål i forhold til utfordringene med serveren du nevnte):

 

(Klippet fra innlegg #7):

Permanent sidelenke: http:................................

Permanent bildelenke: http:................................

 

For å få det til å ligge slik, er det satt inn to harde mellomrom etter Sidelenke ( ) og ett hardt mellomrom etter Bildelenke.'

 

Når de to mellomrommene ( ) tas bort, kan de erstattes av ett vanlig mellomrom?

Det ser ut som URL'en ikke kan stå rett inntil kolonet, for da er det fremdeles noen som får ugyldige lenker,

selv om problemet ble løst for mange av oss forrige gang.

Share this post


Link to post
Share on other sites
Bent Vangli

Jeg har nok blandet med versjoner igjen, men nå er det satt riktig :unsure:

 

Mvh Bent

Share this post


Link to post
Share on other sites
Bent Vangli

For de skannede kirkebøkene er det nå gjort en endring på den permanente sidelenken. Klikk på denne lenken og riktig del skal merkes. Prøv gjerne også med høyreklikk. Dette skal gjøre det enklere å kopiere lenka.

 

P.S. Funksjonaliteten krever at Javascript virker på din PC. For at det skal virke kan det for noen være nødvendig å oppdatere internt mellomlager på PCen. Trykk derfor Ctrl+F5 for å gjøre dette.

 

Mvh Bent

Share this post


Link to post
Share on other sites
Solveig R Håklev

For de skannede kirkebøkene er det nå gjort en endring på den permanente sidelenken. Klikk på denne lenken og riktig del skal merkes. Prøv gjerne også med høyreklikk. Dette skal gjøre det enklere å kopiere lenka.

 

P.S. Funksjonaliteten krever at Javascript virker på din PC. For at det skal virke kan det for noen være nødvendig å oppdatere internt mellomlager på PCen. Trykk derfor Ctrl+F5 for å gjøre dette.

 

Mvh Bent

 

Skal man da få med kildeinformasjonen på toppen slik det var før ?

 

http://forum.arkivverket.no/topic/188303-tester/

 

Får ikke det til :wacko:

Share this post


Link to post
Share on other sites
Espen Tjernshaugen

For de skannede kirkebøkene er det nå gjort en endring på den permanente sidelenken. Klikk på denne lenken og riktig del skal merkes. Prøv gjerne også med høyreklikk. Dette skal gjøre det enklere å kopiere lenka.

 

P.S. Funksjonaliteten krever at Javascript virker på din PC. For at det skal virke kan det for noen være nødvendig å oppdatere internt mellomlager på PCen. Trykk derfor Ctrl+F5 for å gjøre dette.

 

Mvh Bent

 

Dette ble meningsløst, nå er det jo umulig å kopiere kildeinformasjon og sidelenke i samme handling.

Share this post


Link to post
Share on other sites
Frank H. Johansen

Enig med siste innlegg!

 

Det er viktigere å kunne kopiere all kildeinformasjon i én handling enn å slippe et ekstra museklikk for å få kopiert permanent sidelenke.

Share this post


Link to post
Share on other sites
Bent Vangli

Det tenkte jeg ikke på. Rart med det, det ene ønsket slår i hjel det andre. Jeg skal ut med en annen endring i dag, så om jeg ikke finner en alternativ vei får jeg heller reverse dette. Mvh Bent

Share this post


Link to post
Share on other sites
Bent Vangli

Vel, da ble det en Ole Brum løsning. Nå virker begge deler så vidt jeg kan se.

 

Takk for tilbakemeldingen.

 

Mvh Bent

Share this post


Link to post
Share on other sites
Inger Karin Haarbye

Takk, det ser bra ut! :)

Share this post


Link to post
Share on other sites
Torbjørn Igelkjøn

Slik eg forstår det er det berre sjølve bildelenka som vert merka når ein klikkar på den. Dersom ein f. eks. skal klistre dette inn i forumdebattar er det aktuelt å ha med følgjande (eksempel):

 

Kildeinformasjon: Sogn og Fjordane fylke, Holmedal i Fjaler, Klokkerbok nr. B 3 (1913-1940), Fødte og døpte 1913, side 4.

Permanent sidelenke: http://www.arkivverket.no/URN:kb_read?idx_kildeid=2077&idx_id=2077&uid=ny&idx_side=-6

 

Er det mogeleg å la heile feltet (unntatt bildelenka) verte merka på ein gong med eit enkelt museklikk?

Share this post


Link to post
Share on other sites
Bent Vangli

Hei Torbjørn

 

Meningen ved å kunne klikke på den permanente billedlenka for å merke den, var at at det ellers er lett å få med et mellomrom, hvoretter lenka for noen blir ubrukelig når den limes inn. Se innlegg blant annet tidligere i denne tråden. Behov ellers bør nok kunne dekkes ved å merke område på vanlig måte, typisk ved å holde venstre museknapp ned og dra musen over teksten en skal ha med seg.

 

Mvh Bent

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.